use strict;
my $str = '[
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 12:52:18",
"Extraction date": "2024-03-02 13:51:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 18:59:18",
"Extraction date": "2024-03-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2023-01-28 18:59:18",
"Extraction date": "2023-02-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2023-02-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
}
]';
my $regex = qr/(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}