# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])"
test_str = ("[\n"
" {\n"
" \"Assigned to\": \"Jones, Francis\",\n"
" \"Cost\": 3,\n"
" \"Created date\": \"2024-02-28 12:52:18\",\n"
" \"Extraction date\": \"2024-03-02 13:51:00\",\n"
" \"ID\": 12345,\n"
" \"Initial Cost\": 3,\n"
" \"Location\": \"Sites\",\n"
" \"Path\": \"Sites\\\\FY1\\\\S3\",\n"
" \"Priority\": 1,\n"
" \"State\": \"In Progress\",\n"
" \"Status Change date\": \"2024-03-05 16:33:23\",\n"
" \"Tags\": \"Europe; Finance\",\n"
" \"Title\": \"Ensure correct routing of orders\",\n"
" \"Updated date\": \"2024-03-05 16:33:23\",\n"
" \"Warranty\": false,\n"
" \"Wave Quarter\": \"Q2 22\",\n"
" \"Work Item Type\": \"Request\"\n"
" },\n"
" {\n"
" \"Assigned to\": \"Jones, Francis\",\n"
" \"Cost\": 3,\n"
" \"Created date\": \"2024-02-28 18:59:18\",\n"
" \"Extraction date\": \"2024-03-05 16:31:00\",\n"
" \"ID\": 12345,\n"
" \"Initial Cost\": 3,\n"
" \"Location\": \"Sites\",\n"
" \"Path\": \"Sites\\\\FY1\\\\S3\",\n"
" \"Priority\": 1,\n"
" \"State\": \"In Progress\",\n"
" \"Status Change date\": \"2024-03-05 16:33:23\",\n"
" \"Tags\": \"Europe; Finance\",\n"
" \"Title\": \"Ensure correct routing of orders\",\n"
" \"Updated date\": \"2024-03-05 16:33:23\",\n"
" \"Warranty\": false,\n"
" \"Wave Quarter\": \"Q2 22\",\n"
" \"Work Item Type\": \"Request\"\n"
" },\n"
" {\n"
" \"Assigned to\": \"Jones, Francis\",\n"
" \"Cost\": 3,\n"
" \"Created date\": \"2023-01-28 18:59:18\",\n"
" \"Extraction date\": \"2023-02-05 16:31:00\",\n"
" \"ID\": 12345,\n"
" \"Initial Cost\": 3,\n"
" \"Location\": \"Sites\",\n"
" \"Path\": \"Sites\\\\FY1\\\\S3\",\n"
" \"Priority\": 1,\n"
" \"State\": \"In Progress\",\n"
" \"Status Change date\": \"2023-02-05 16:33:23\",\n"
" \"Tags\": \"Europe; Finance\",\n"
" \"Title\": \"Ensure correct routing of orders\",\n"
" \"Updated date\": \"2024-03-05 16:33:23\",\n"
" \"Warranty\": false,\n"
" \"Wave Quarter\": \"Q2 22\",\n"
" \"Work Item Type\": \"Request\"\n"
" }\n"
"]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.