using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])";
string input = @"[
{
""Assigned to"": ""Jones, Francis"",
""Cost"": 3,
""Created date"": ""2024-02-28 12:52:18"",
""Extraction date"": ""2024-03-02 13:51:00"",
""ID"": 12345,
""Initial Cost"": 3,
""Location"": ""Sites"",
""Path"": ""Sites\\FY1\\S3"",
""Priority"": 1,
""State"": ""In Progress"",
""Status Change date"": ""2024-03-05 16:33:23"",
""Tags"": ""Europe; Finance"",
""Title"": ""Ensure correct routing of orders"",
""Updated date"": ""2024-03-05 16:33:23"",
""Warranty"": false,
""Wave Quarter"": ""Q2 22"",
""Work Item Type"": ""Request""
},
{
""Assigned to"": ""Jones, Francis"",
""Cost"": 3,
""Created date"": ""2024-02-28 18:59:18"",
""Extraction date"": ""2024-03-05 16:31:00"",
""ID"": 12345,
""Initial Cost"": 3,
""Location"": ""Sites"",
""Path"": ""Sites\\FY1\\S3"",
""Priority"": 1,
""State"": ""In Progress"",
""Status Change date"": ""2024-03-05 16:33:23"",
""Tags"": ""Europe; Finance"",
""Title"": ""Ensure correct routing of orders"",
""Updated date"": ""2024-03-05 16:33:23"",
""Warranty"": false,
""Wave Quarter"": ""Q2 22"",
""Work Item Type"": ""Request""
},
{
""Assigned to"": ""Jones, Francis"",
""Cost"": 3,
""Created date"": ""2023-01-28 18:59:18"",
""Extraction date"": ""2023-02-05 16:31:00"",
""ID"": 12345,
""Initial Cost"": 3,
""Location"": ""Sites"",
""Path"": ""Sites\\FY1\\S3"",
""Priority"": 1,
""State"": ""In Progress"",
""Status Change date"": ""2023-02-05 16:33:23"",
""Tags"": ""Europe; Finance"",
""Title"": ""Ensure correct routing of orders"",
""Updated date"": ""2024-03-05 16:33:23"",
""Warranty"": false,
""Wave Quarter"": ""Q2 22"",
""Work Item Type"": ""Request""
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}