#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$"
Local $sString = "mandy8055@gmail.com" & @CRLF & _
"pwd.abcd.qwerty@fgh" & @CRLF & _
"pwd..abcd@d" & @CRLF & _
"pwd.abcd--abcd@gna." & @CRLF & _
"pwd.abcd@gma@" & @CRLF & _
"@dfgca@gmail.com" & @CRLF & _
"pwd--@gmail.com" & @CRLF & _
"pwd-@gmail.com" & @CRLF & _
"pwd@.com" & @CRLF & _
"vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com" & @CRLF & _
"csnmlcsncscn_cnocnwocnow@gngnognao.com" & @CRLF & _
"afafhakfhkaW@gmail.com" & @CRLF & _
"ashaljaldj123-dad.adlad@gmail.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")