import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.+?(?:\\.-|\\.\\.|--|-@|\\.@|@\\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$";
final String string = "mandy8055@gmail.com\n"
+ "pwd.abcd.qwerty@fgh\n"
+ "pwd..abcd@d\n"
+ "pwd.abcd--abcd@gna.\n"
+ "pwd.abcd@gma@\n"
+ "@dfgca@gmail.com\n"
+ "pwd--@gmail.com\n"
+ "pwd-@gmail.com\n"
+ "pwd@.com\n"
+ "vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com\n"
+ "csnmlcsncscn_cnocnwocnow@gngnognao.com\n"
+ "afafhakfhkaW@gmail.com\n"
+ "ashaljaldj123-dad.adlad@gmail.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}