use strict;
my $str = 'mandy8055@gmail.com
pwd.abcd.qwerty@fgh
pwd..abcd@d
pwd.abcd--abcd@gna.
pwd.abcd@gma@
@dfgca@gmail.com
pwd--@gmail.com
pwd-@gmail.com
pwd@.com
vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com
csnmlcsncscn_cnocnwocnow@gngnognao.com
afafhakfhkaW@gmail.com
ashaljaldj123-dad.adlad@gmail.com
';
my $regex = qr/^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}