const regex = /^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.+?(?:\\.-|\\.\\.|--|-@|\\.@|@\\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$', 'gm')
const str = `mandy8055@gmail.com
pwd.abcd.qwerty@fgh
pwd..abcd@d
pwd.abcd--abcd@gna.
pwd.abcd@gma@
@dfgca@gmail.com
pwd--@gmail.com
pwd-@gmail.com
pwd@.com
vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com
csnmlcsncscn_cnocnwocnow@gngnognao.com
afafhakfhkaW@gmail.com
ashaljaldj123-dad.adlad@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}