$re = '/^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$/m';
$str = 'mandy8055@gmail.com
pwd.abcd.qwerty@fgh
pwd..abcd@d
pwd.abcd--abcd@gna.
pwd.abcd@gma@
@dfgca@gmail.com
pwd--@gmail.com
pwd-@gmail.com
pwd@.com
vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com
csnmlcsncscn_cnocnwocnow@gngnognao.com
afafhakfhkaW@gmail.com
ashaljaldj123-dad.adlad@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);