using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$";
string input = @"mandy8055@gmail.com
pwd.abcd.qwerty@fgh
pwd..abcd@d
pwd.abcd--abcd@gna.
pwd.abcd@gma@
@dfgca@gmail.com
pwd--@gmail.com
pwd-@gmail.com
pwd@.com
vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com
csnmlcsncscn_cnocnwocnow@gngnognao.com
afafhakfhkaW@gmail.com
ashaljaldj123-dad.adlad@gmail.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}