import Foundation
let pattern = #"^(?!.+?(?:\.-|\.\.|--|-@|\.@|@\.).+?)[^.-@ ][a-z0-9_.-]+@[a-z0-9_.-]+(?<=[^.-@ ])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mandy8055@gmail.com
pwd.abcd.qwerty@fgh
pwd..abcd@d
pwd.abcd--abcd@gna.
pwd.abcd@gma@
@dfgca@gmail.com
pwd--@gmail.com
pwd-@gmail.com
pwd@.com
vbabbvalba_ncskcnskcnsk@ncsncsncwvnowvn@nsonvson.com
csnmlcsncscn_cnocnwocnow@gngnognao.com
afafhakfhkaW@gmail.com
ashaljaldj123-dad.adlad@gmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)