# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n (\d)/\1/gm;t' <<< "
this
1. is
2. some
3. text
"