$re = '/\n (\d)/m';
$str = '
this
1. is
2. some
3. text
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;