use strict;
my $str = '
this
1. is
2. some
3. text
';
my $regex = qr/\n (\d)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";