const regex = new RegExp('\\n (\\d)', 'gm')
const str = `
this
1. is
2. some
3. text
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);