#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n (\d)"
Local $sString = "" & @CRLF & _
" this " & @CRLF & _
" 1. is " & @CRLF & _
" 2. some " & @CRLF & _
" 3. text " & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)