import re
regex = re.compile(r"\n (\d)", flags=re.MULTILINE)
test_str = ("\n"
" this \n"
" 1. is \n"
" 2. some \n"
" 3. text \n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)