package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n (\d)`)
var str = `
this
1. is
2. some
3. text
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}