# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\R{2})\R+|(\R){2}/$1$2/gm;t' <<< "line1
line2
line3
line4
line5"