#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\R{2})\R+|(\R){2}"
Local $sString = "line1" & @CRLF & _
"" & @CRLF & _
"line2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"line3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"line4" & @CRLF & _
"" & @CRLF & _
"line5"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)