package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\R{2})\R+|(\R){2}`)
var str = `line1
line2
line3
line4
line5`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}