const regex = /(\R{2})\R+|(\R){2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\R{2})\\R+|(\\R){2}', 'gm')
const str = `line1
line2
line3
line4
line5`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);