import re
regex = re.compile(r"(\R{2})\R+|(\R){2}", flags=re.MULTILINE)
test_str = ("line1\n\n"
"line2\n\n\n\n"
"line3\n\n\n\n\n"
"line4\n\n"
"line5")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)