$re = '/(\R{2})\R+|(\R){2}/m';
$str = 'line1
line2
line3
line4
line5';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;