# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/dog ?//gm;t' <<< "dog cat dog pig dog ant dog elk dog cow"