$re = '/dog ?/m';
$str = 'dog cat dog pig dog ant dog elk dog cow';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;