re = /dog ?/m
str = 'dog cat dog pig dog ant dog elk dog cow'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result