using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dog ?";
string substitution = @"";
string input = @"dog cat dog pig dog ant dog elk dog cow";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}