package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)dog ?`)
var str = `dog cat dog pig dog ant dog elk dog cow`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}