const regex = /dog ?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('dog ?', 'gm')
const str = `dog cat dog pig dog ant dog elk dog cow`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);