use strict;
my $str = 'dog cat dog pig dog ant dog elk dog cow';
my $regex = qr/dog ?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";