#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<ins_all> # insertion can be multilines" & @CRLF & _
" (?<!\\)\+{2} # Start with 2 +" & @CRLF & _
" (?!\n) # but not followed by a new line to avoid any previous + getting caught" & @CRLF & _
" (?<ins_content> # the content which excludes any + unless they are escaped" & @CRLF & _
" (?>\\[\+]|[^\+])*+" & @CRLF & _
" )" & @CRLF & _
" (?<!\\)\+{2} # terminated by 2 +" & @CRLF & _
")"
Local $sString = "Tickets for the event are ~~€5~~ ++€10++"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")