import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ins_all> # insertion can be multilines\n"
+ " (?<!\\\\)\\+{2} # Start with 2 +\n"
+ " (?!\\n) # but not followed by a new line to avoid any previous + getting caught\n"
+ " (?<ins_content> # the content which excludes any + unless they are escaped\n"
+ " (?>\\\\[\\+]|[^\\+])*+\n"
+ " )\n"
+ " (?<!\\\\)\\+{2} # terminated by 2 +\n"
+ ")";
final String string = "Tickets for the event are ~~€5~~ ++€10++";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}