import Foundation
let pattern = ##"""
(?<ins_all> # insertion can be multilines
(?<!\\)\+{2} # Start with 2 +
(?!\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\[\+]|[^\+])*+
)
(?<!\\)\+{2} # terminated by 2 +
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"Tickets for the event are ~~€5~~ ++€10++"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)