$re = '/(?<ins_all> # insertion can be multilines
(?<!\\\\)\+{2} # Start with 2 +
(?!\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\\\[\+]|[^\+])*+
)
(?<!\\\\)\+{2} # terminated by 2 +
)/mx';
$str = 'Tickets for the event are ~~€5~~ ++€10++';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);