const regex = /(?<ins_all> # insertion can be multilines
(?<!\\)\+{2} # Start with 2 +
(?!\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\[\+]|[^\+])*+
)
(?<!\\)\+{2} # terminated by 2 +
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<ins_all> # insertion can be multilines
(?<!\\\\)\\+{2} # Start with 2 +
(?!\\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\\\[\\+]|[^\\+])*+
)
(?<!\\\\)\\+{2} # terminated by 2 +
)', 'gm')
const str = `Tickets for the event are ~~€5~~ ++€10++`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}