// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?<ins_all> # insertion can be multilines
(?<!\\)\+{2} # Start with 2 +
(?!\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\[\+]|[^\+])*+
)
(?<!\\)\+{2} # terminated by 2 +
)").unwrap();
let string = "Tickets for the event are ~~€5~~ ++€10++";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}