re = /(?<ins_all> # insertion can be multilines
(?<!\\)\+{2} # Start with 2 +
(?!\n) # but not followed by a new line to avoid any previous + getting caught
(?<ins_content> # the content which excludes any + unless they are escaped
(?>\\[\+]|[^\+])*+
)
(?<!\\)\+{2} # terminated by 2 +
)/mx
str = 'Tickets for the event are ~~€5~~ ++€10++'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end