#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([0-9]+)-([0-9]+))|([0-9]+)"
Local $sString = "3-5" & @CRLF & _
"10-14" & @CRLF & _
"16-20" & @CRLF & _
"12-18" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"5" & @CRLF & _
"8" & @CRLF & _
"11" & @CRLF & _
"17" & @CRLF & _
"32"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")