import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9]+)-([0-9]+))|([0-9]+)";
final String string = "3-5\n"
+ "10-14\n"
+ "16-20\n"
+ "12-18\n\n"
+ "1\n"
+ "5\n"
+ "8\n"
+ "11\n"
+ "17\n"
+ "32";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}