$re = '/(([0-9]+)-([0-9]+))|([0-9]+)/m';
$str = '3-5
10-14
16-20
12-18
1
5
8
11
17
32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);