// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([0-9]+)-([0-9]+))|([0-9]+)").unwrap();
let string = "3-5
10-14
16-20
12-18
1
5
8
11
17
32";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}