import re
regex = re.compile(r"(([0-9]+)-([0-9]+))|([0-9]+)", flags=re.MULTILINE)
test_str = ("3-5\n"
"10-14\n"
"16-20\n"
"12-18\n\n"
"1\n"
"5\n"
"8\n"
"11\n"
"17\n"
"32")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")