package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-9]+)-([0-9]+))|([0-9]+)`)
var str = `3-5
10-14
16-20
12-18
1
5
8
11
17
32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}