re = /(([0-9]+)-([0-9]+))|([0-9]+)/m
str = '3-5
10-14
16-20
12-18
1
5
8
11
17
32'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end