#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
" (?!" & @CRLF & _
" (?:(?=.*0)(?=.*1)(?=.*2))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*1)(?=.*2)(?=.*3))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*2)(?=.*3)(?=.*4))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*3)(?=.*4)(?=.*5))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*4)(?=.*5)(?=.*6))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*5)(?=.*6)(?=.*7))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*6)(?=.*7)(?=.*8))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=.*7)(?=.*9)(?=.*9))" & @CRLF & _
" )" & @CRLF & _
" .*" & @CRLF & _
""
Local $sString = "124" & @CRLF & _
"124578" & @CRLF & _
"482715" & @CRLF & _
"123" & @CRLF & _
"312" & @CRLF & _
"1245789" & @CRLF & _
"7492158" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")