using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?!
(?:(?=.*0)(?=.*1)(?=.*2))
|
(?:(?=.*1)(?=.*2)(?=.*3))
|
(?:(?=.*2)(?=.*3)(?=.*4))
|
(?:(?=.*3)(?=.*4)(?=.*5))
|
(?:(?=.*4)(?=.*5)(?=.*6))
|
(?:(?=.*5)(?=.*6)(?=.*7))
|
(?:(?=.*6)(?=.*7)(?=.*8))
|
(?:(?=.*7)(?=.*9)(?=.*9))
)
.*
";
string input = @"124
124578
482715
123
312
1245789
7492158
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}