# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?!
(?:(?=.*0)(?=.*1)(?=.*2))
|
(?:(?=.*1)(?=.*2)(?=.*3))
|
(?:(?=.*2)(?=.*3)(?=.*4))
|
(?:(?=.*3)(?=.*4)(?=.*5))
|
(?:(?=.*4)(?=.*5)(?=.*6))
|
(?:(?=.*5)(?=.*6)(?=.*7))
|
(?:(?=.*6)(?=.*7)(?=.*8))
|
(?:(?=.*7)(?=.*9)(?=.*9))
)
.*
"""
test_str = ("124\n"
"124578\n"
"482715\n"
"123\n"
"312\n"
"1245789\n"
"7492158\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.