import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?!\n"
+ " (?:(?=.*0)(?=.*1)(?=.*2))\n"
+ " |\n"
+ " (?:(?=.*1)(?=.*2)(?=.*3))\n"
+ " |\n"
+ " (?:(?=.*2)(?=.*3)(?=.*4))\n"
+ " |\n"
+ " (?:(?=.*3)(?=.*4)(?=.*5))\n"
+ " |\n"
+ " (?:(?=.*4)(?=.*5)(?=.*6))\n"
+ " |\n"
+ " (?:(?=.*5)(?=.*6)(?=.*7))\n"
+ " |\n"
+ " (?:(?=.*6)(?=.*7)(?=.*8))\n"
+ " |\n"
+ " (?:(?=.*7)(?=.*9)(?=.*9))\n"
+ " )\n"
+ " .*\n";
final String string = "124\n"
+ "124578\n"
+ "482715\n"
+ "123\n"
+ "312\n"
+ "1245789\n"
+ "7492158\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}