// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?!
(?:(?=.*0)(?=.*1)(?=.*2))
|
(?:(?=.*1)(?=.*2)(?=.*3))
|
(?:(?=.*2)(?=.*3)(?=.*4))
|
(?:(?=.*3)(?=.*4)(?=.*5))
|
(?:(?=.*4)(?=.*5)(?=.*6))
|
(?:(?=.*5)(?=.*6)(?=.*7))
|
(?:(?=.*6)(?=.*7)(?=.*8))
|
(?:(?=.*7)(?=.*9)(?=.*9))
)
.*
").unwrap();
let string = "124
124578
482715
123
312
1245789
7492158
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}