use strict;
my $str = '124
124578
482715
123
312
1245789
7492158
';
my $regex = qr/^
(?!
(?:(?=.*0)(?=.*1)(?=.*2))
|
(?:(?=.*1)(?=.*2)(?=.*3))
|
(?:(?=.*2)(?=.*3)(?=.*4))
|
(?:(?=.*3)(?=.*4)(?=.*5))
|
(?:(?=.*4)(?=.*5)(?=.*6))
|
(?:(?=.*5)(?=.*6)(?=.*7))
|
(?:(?=.*6)(?=.*7)(?=.*8))
|
(?:(?=.*7)(?=.*9)(?=.*9))
)
.*
/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}